$re = '/^(?:;+)\R*/m';
$str = ';;;
z;
hh ;d;
;
;
;
12;b
;
bb;b
;;;
;;';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;