package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.ovh\)`)
var str = `[test@test.ovh](mailto:test@test.ovh)
[test@test.de](mailto:test@test.de)
[email](mailto:test@test.ovh.com)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}