$re = '/\.ovh\)/m';
$str = '[test@test.ovh](mailto:test@test.ovh)
[test@test.de](mailto:test@test.de)
[email](mailto:test@test.ovh.com)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);