re = /\.ovh\)/m
str = '[test@test.ovh](mailto:test@test.ovh)
[test@test.de](mailto:test@test.de)
[email](mailto:test@test.ovh.com)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end