using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<BLOCK_START>.*?<BLOCK_END>";
string input = @"<BLOCK_START>
my text
<BLOCK_END>
<BLOCK_START>
my text
<BLOCK_END>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}