re = /(?s)<BLOCK_START>.*?<BLOCK_END>/m
str = '<BLOCK_START>
my text
<BLOCK_END>
<BLOCK_START>
my text
<BLOCK_END>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end