package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)<BLOCK_START>.*?<BLOCK_END>`)
var str = `<BLOCK_START>
my text
<BLOCK_END>
<BLOCK_START>
my text
<BLOCK_END>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}