#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*\d+\s+(\w+\s+\d+\s+\d+\s+)\d+\s+\d+\s+\d+\s+\d+\s+\d+\s+(\w+)"
Local $sString = " 2555 texttext 0 100 100 0 0 0 0 lowness 0" & @CRLF & _
" 2557 texttext 10 650 660 0 0 0 0 lowness 0" & @CRLF & _
" 2564 texttext 0 30 30 0 0 0 0 lowness 0" & @CRLF & _
" 2566 texttext 0 0 0 0 0 0 0 lowness 0" & @CRLF & _
" 2567 texttext 10 70 80 0 0 0 0 lowness 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")