import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\d+\\s+(\\w+\\s+\\d+\\s+\\d+\\s+)\\d+\\s+\\d+\\s+\\d+\\s+\\d+\\s+\\d+\\s+(\\w+)";
final String string = " 2555 texttext 0 100 100 0 0 0 0 lowness 0\n"
+ " 2557 texttext 10 650 660 0 0 0 0 lowness 0\n"
+ " 2564 texttext 0 30 30 0 0 0 0 lowness 0\n"
+ " 2566 texttext 0 0 0 0 0 0 0 lowness 0\n"
+ " 2567 texttext 10 70 80 0 0 0 0 lowness 0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}