import re
regex = re.compile(r"^\s*\d+\s+(\w+\s+\d+\s+\d+\s+)\d+\s+\d+\s+\d+\s+\d+\s+\d+\s+(\w+)", flags=re.MULTILINE)
test_str = (" 2555 texttext 0 100 100 0 0 0 0 lowness 0\n"
" 2557 texttext 10 650 660 0 0 0 0 lowness 0\n"
" 2564 texttext 0 30 30 0 0 0 0 lowness 0\n"
" 2566 texttext 0 0 0 0 0 0 0 lowness 0\n"
" 2567 texttext 10 70 80 0 0 0 0 lowness 0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")