const regex = new RegExp('(uno|dos|tres|cuatro|cinco|seis|siete|ocho|nueve|diez|once|doce|trece|catorce|quince|dieciséis|diecisiete|dieciocho|diecinueve|veinte|veintiuno
|veintidós|veintitrés|veinticuatro|veinticinco|veintiséis|veintisiete|veintiocho|veintinueve|treinta|treinta y uno)(?:[ ]de[ ])?(enero|febrero|
marzo|abril|mayo|junio|julio|agosto|septiembre|octubre|noviembre|diciembre)[ ]?(?:de|del)?[ ]?(?:año)?[ ]?(dos[ ])?(mil)[ ]?(cien|doscient
os|trescientos|cuatrocientos|quinientos|seiscientos|setecientos|ochocientos|novecientos)?[ ]?(diez|once|doce|trece|catorce|quince|dieciséis|die
cisiete|dieciocho|diecinueve|veinte|veintiuno|veintidós|veintitrés|veinticuatro|veinticinco|veintiséis|veintisiete|veintiocho|veintinueve|treinta|cuarenta|cincuenta|sesenta|setenta|ochenta|noventa)?(?:[ ]y[ ])?(uno|dos|tres|cuatro|cinco|seis|siete|ocho|nueve)?', 'gmi')
const str = `siete de Enero dos mil diecinueve`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}