$re = '/(uno|dos|tres|cuatro|cinco|seis|siete|ocho|nueve|diez|once|doce|trece|catorce|quince|dieciséis|diecisiete|dieciocho|diecinueve|veinte|veintiuno
|veintidós|veintitrés|veinticuatro|veinticinco|veintiséis|veintisiete|veintiocho|veintinueve|treinta|treinta y uno)(?:[ ]de[ ])?(enero|febrero|
marzo|abril|mayo|junio|julio|agosto|septiembre|octubre|noviembre|diciembre)[ ]?(?:de|del)?[ ]?(?:año)?[ ]?(dos[ ])?(mil)[ ]?(cien|doscient
os|trescientos|cuatrocientos|quinientos|seiscientos|setecientos|ochocientos|novecientos)?[ ]?(diez|once|doce|trece|catorce|quince|dieciséis|die
cisiete|dieciocho|diecinueve|veinte|veintiuno|veintidós|veintitrés|veinticuatro|veinticinco|veintiséis|veintisiete|veintiocho|veintinueve|treinta|cuarenta|cincuenta|sesenta|setenta|ochenta|noventa)?(?:[ ]y[ ])?(uno|dos|tres|cuatro|cinco|seis|siete|ocho|nueve)?/mi';
$str = 'siete de Enero dos mil diecinueve';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);