use strict;
my $str = 'siete de Enero dos mil diecinueve';
my $regex = qr/(uno|dos|tres|cuatro|cinco|seis|siete|ocho|nueve|diez|once|doce|trece|catorce|quince|dieciséis|diecisiete|dieciocho|diecinueve|veinte|veintiuno
|veintidós|veintitrés|veinticuatro|veinticinco|veintiséis|veintisiete|veintiocho|veintinueve|treinta|treinta y uno)(?:[ ]de[ ])?(enero|febrero|
marzo|abril|mayo|junio|julio|agosto|septiembre|octubre|noviembre|diciembre)[ ]?(?:de|del)?[ ]?(?:año)?[ ]?(dos[ ])?(mil)[ ]?(cien|doscient
os|trescientos|cuatrocientos|quinientos|seiscientos|setecientos|ochocientos|novecientos)?[ ]?(diez|once|doce|trece|catorce|quince|dieciséis|die
cisiete|dieciocho|diecinueve|veinte|veintiuno|veintidós|veintitrés|veinticuatro|veinticinco|veintiséis|veintisiete|veintiocho|veintinueve|treinta|cuarenta|cincuenta|sesenta|setenta|ochenta|noventa)?(?:[ ]y[ ])?(uno|dos|tres|cuatro|cinco|seis|siete|ocho|nueve)?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}