package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ID123456_(?:SIT|UAT|TRA)(?:,(SIT|UAT))*`)
var str = ` - should match with regex
ID123456_SIT,UAT
ID123456_UAT,SIT
ID123456_SIT
ID123456_UAT
ID123456_TRA,SIT,UAT
- should match with regex`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}