const regex = /^ID123456_(?:SIT|UAT|TRA)(?:,(SIT|UAT))*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ID123456_(?:SIT|UAT|TRA)(?:,(SIT|UAT))*', 'gm')
const str = ` - should match with regex
ID123456_SIT,UAT
ID123456_UAT,SIT
ID123456_SIT
ID123456_UAT
ID123456_TRA,SIT,UAT
- should match with regex`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}