import re
regex = re.compile(r"^ID123456_(?:SIT|UAT|TRA)(?:,(SIT|UAT))*", flags=re.MULTILINE)
test_str = (" - should match with regex\n"
"ID123456_SIT,UAT\n"
"ID123456_UAT,SIT\n"
"ID123456_SIT\n"
"ID123456_UAT\n\n"
"ID123456_TRA,SIT,UAT\n"
" - should match with regex")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")