using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ID123456_(?=.*(?:SIT|UAT)).*";
string input = @" - should match with regex
ID123456_SIT,UAT
ID123456_UAT,SIT
ID123456_SIT
ID123456_UAT
ID123456_TRA,SIT,UAT
- should match with regex";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}