$re = '/^ID123456_(?=.*(?:SIT|UAT)).*/m';
$str = ' - should match with regex
ID123456_SIT,UAT
ID123456_UAT,SIT
ID123456_SIT
ID123456_UAT
ID123456_TRA,SIT,UAT
- should match with regex';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);