re = /^ID123456_(?=.*(?:SIT|UAT)).*/m
str = ' - should match with regex
ID123456_SIT,UAT
ID123456_UAT,SIT
ID123456_SIT
ID123456_UAT
ID123456_TRA,SIT,UAT
- should match with regex'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end