#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(.*BANK.*\b)(\d{4}\s\d{4}\s\d{4}\s\d{3}?)"
Local $sString = "COMMERCIAL BANK Current - 9109 2345 9876 123" & @CRLF & _
"COMMERCIAL BANK - 9123 4567 8901 234" & @CRLF & _
"COMMERCIAL BANK 9145 6789 0123 456" & @CRLF & _
"COMMERCIAL BANK OF U.S 9156 7890 1234 567" & @CRLF & _
"BANK OF U.S 9112 3456 7890 123 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")