import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*BANK.*\\b)(\\d{4}\\s\\d{4}\\s\\d{4}\\s\\d{3}?)";
final String string = "COMMERCIAL BANK Current - 9109 2345 9876 123\n"
+ "COMMERCIAL BANK - 9123 4567 8901 234\n"
+ "COMMERCIAL BANK 9145 6789 0123 456\n"
+ "COMMERCIAL BANK OF U.S 9156 7890 1234 567\n"
+ "BANK OF U.S 9112 3456 7890 123 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}