$re = '/(.*BANK.*\b)(\d{4}\s\d{4}\s\d{4}\s\d{3}?)/mi';
$str = 'COMMERCIAL BANK Current - 9109 2345 9876 123
COMMERCIAL BANK - 9123 4567 8901 234
COMMERCIAL BANK 9145 6789 0123 456
COMMERCIAL BANK OF U.S 9156 7890 1234 567
BANK OF U.S 9112 3456 7890 123 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);