const regex = /\b(?!goose\b)\w+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!goose\\b)\\w+\\b', 'gm')
const str = `goose random! goose! goose goose random random, goose gooses1 test goose goose goose random222111 goose1 123123 asasdf asdf mongoose wildgoose,`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);