import re
regex = re.compile(r"\b(?!goose\b)\w+\b", flags=re.MULTILINE)
test_str = "goose random! goose! goose goose random random, goose gooses1 test goose goose goose random222111 goose1 123123 asasdf asdf mongoose wildgoose,"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)