re = /\b(?!goose\b)\w+\b/m
str = 'goose random! goose! goose goose random random, goose gooses1 test goose goose goose random222111 goose1 123123 asasdf asdf mongoose wildgoose,'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result