using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h(?:1>|2>Obituary\sfor\s)\K[^><]+";
string input = @"<h2>Obituary for John Doe</h2>
<h1>James Michael Lee</h1>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}