re = /<h(?:1>|2>Obituary\sfor\s)\K[^><]+/m
str = '<h2>Obituary for John Doe</h2>
<h1>James Michael Lee</h1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end