$re = '/<h(?:1>|2>Obituary\sfor\s)\K[^><]+/m';
$str = '<h2>Obituary for John Doe</h2>
<h1>James Michael Lee</h1>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);