#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)foo \d+|\d+ foo(?! \d+)"
Local $sString = "1234 foo" & @CRLF & _
"foo 1234" & @CRLF & _
"1234 foo 1234 " & @CRLF & _
"foo 1234" & @CRLF & _
"foo 1234 1234 foo" & @CRLF & _
"foo 1234 foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")