$re = '/foo \d+|\d+ foo(?! \d+)/m';
$str = '1234 foo
foo 1234
1234 foo 1234
foo 1234
foo 1234 1234 foo
foo 1234 foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);