using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"foo \d+|\d+ foo(?! \d+)";
string input = @"1234 foo
foo 1234
1234 foo 1234
foo 1234
foo 1234 1234 foo
foo 1234 foo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}