#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)(?<=<table>)\s*<tr>\s*<td>([a-z0-9 ]*)<\/td>\s*<\/tr>"
Local $sString = "<table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Text A</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <table> <!-- Notice this is an inner scope table -->" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Text B</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>" & @CRLF & _
"" & @CRLF & _
"<table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
" <table> <!-- Notice this is an inner scope table -->" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Text C</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>" & @CRLF & _
"" & @CRLF & _
"<table>" & @CRLF & _
" <tr>" & @CRLF & _
" <td>Text D</td>" & @CRLF & _
" </tr>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")