# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=<table>)\s*<tr>\s*<td>([a-z0-9 ]*)<\/td>\s*<\/tr>"
test_str = ("<table>\n"
" <tr>\n"
" <td>Text A</td>\n"
" </tr>\n"
" <tr>\n"
" <td>\n"
" <table> <!-- Notice this is an inner scope table -->\n"
" <tr>\n"
" <td>Text B</td>\n"
" </tr>\n"
" </table>\n"
" </td>\n"
" </tr>\n"
"</table>\n\n"
"<table>\n"
" <tr>\n"
" <td>\n"
" <table> <!-- Notice this is an inner scope table -->\n"
" <tr>\n"
" <td>Text C</td>\n"
" </tr>\n"
" </table>\n"
" </td>\n"
" </tr>\n"
"</table>\n\n"
"<table>\n"
" <tr>\n"
" <td>Text D</td>\n"
" </tr>\n"
"</table>")
matches = re.finditer(regex, test_str, re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.