import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<table>)\\s*<tr>\\s*<td>([a-z0-9 ]*)<\\/td>\\s*<\\/tr>";
final String string = "<table>\n"
+ " <tr>\n"
+ " <td>Text A</td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td>\n"
+ " <table> <!-- Notice this is an inner scope table -->\n"
+ " <tr>\n"
+ " <td>Text B</td>\n"
+ " </tr>\n"
+ " </table>\n"
+ " </td>\n"
+ " </tr>\n"
+ "</table>\n\n"
+ "<table>\n"
+ " <tr>\n"
+ " <td>\n"
+ " <table> <!-- Notice this is an inner scope table -->\n"
+ " <tr>\n"
+ " <td>Text C</td>\n"
+ " </tr>\n"
+ " </table>\n"
+ " </td>\n"
+ " </tr>\n"
+ "</table>\n\n"
+ "<table>\n"
+ " <tr>\n"
+ " <td>Text D</td>\n"
+ " </tr>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}