import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'s'.*)(?'p'[.!])\\n?|(?'s'.*)";
final String string = "EINE ZWEIWÖCHIGE EURAIL-REISE: PARIS, SCHWEIZ UND DEUTSCHLAND\n"
+ "Wenn Du meinen Blog in den letzten Monaten gelesen hast, wirst Du wissen, dass ich im März diesen Jahres während meiner Frühjahresferien zwei Wochen lang durch Europa gereist bin.\n"
+ "Das habe ich in diesen zwei Wochen wirklich ausgenutzt!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}