$re = '/(?\'s\'.*)(?\'p\'[.!])\n?|(?\'s\'.*)/mJ';
$str = 'EINE ZWEIWÖCHIGE EURAIL-REISE: PARIS, SCHWEIZ UND DEUTSCHLAND
Wenn Du meinen Blog in den letzten Monaten gelesen hast, wirst Du wissen, dass ich im März diesen Jahres während meiner Frühjahresferien zwei Wochen lang durch Europa gereist bin.
Das habe ich in diesen zwei Wochen wirklich ausgenutzt!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);