re = /(?'s'.*)(?'p'[.!])\n?|(?'s'.*)/m
str = 'EINE ZWEIWÖCHIGE EURAIL-REISE: PARIS, SCHWEIZ UND DEUTSCHLAND
Wenn Du meinen Blog in den letzten Monaten gelesen hast, wirst Du wissen, dass ich im März diesen Jahres während meiner Frühjahresferien zwei Wochen lang durch Europa gereist bin.
Das habe ich in diesen zwei Wochen wirklich ausgenutzt!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end