#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:0|-?[1-9]\d*|-?[1-9]\d{0,2}(?:,\d{3})+)$"
Local $sString = "561,085" & @CRLF & _
"3,894,320" & @CRLF & _
"-59,099" & @CRLF & _
"1,000" & @CRLF & _
"1000" & @CRLF & _
"-1000" & @CRLF & _
"1" & @CRLF & _
"-1" & @CRLF & _
"0" & @CRLF & _
"" & @CRLF & _
"-01" & @CRLF & _
"01393" & @CRLF & _
"01,300,00" & @CRLF & _
"-04,044"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")