// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:0|-?[1-9]\d*|-?[1-9]\d{0,2}(?:,\d{3})+)$").unwrap();
let string = "561,085
3,894,320
-59,099
1,000
1000
-1000
1
-1
0
-01
01393
01,300,00
-04,044";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}