re = /^(?:0|-?[1-9]\d*|-?[1-9]\d{0,2}(?:,\d{3})+)$/m
str = '561,085
3,894,320
-59,099
1,000
1000
-1000
1
-1
0
-01
01393
01,300,00
-04,044'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end