#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[A-Z]*,"
Local $sString = "JOSE CARLOS RAMON, RODRIGUEZ SOSA."
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)