// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Z]*,").unwrap();
let string = "JOSE CARLOS RAMON, RODRIGUEZ SOSA.";
let substitution = ",";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}