$re = '/\B#[\w\u0600-\u06FF\u200B-\u200E]+\b/m';
$str = '#gfghfghf gfhfghfg fghfghfgh fghfh gfhfghf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);