re = /\B#[\w\u0600-\u06FF\u200B-\u200E]+\b/m
str = '#gfghfghf gfhfghfg fghfghfgh fghfh gfhfghf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end