// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\B#[\w\u0600-\u06FF\u200B-\u200E]+\b").unwrap();
let string = "#gfghfghf gfhfghfg fghfghfgh fghfh gfhfghf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}