package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z][a-zA-Z]+(?:-[A-Z][a-zA-Z]+)?), ([A-Z][a-zA-Z]+\s*(?:[A-Z][a-zA-Z]+|[A-Z]\.)?)`)
var str = `"Kennedy, John"
"Kennedy, John F."
"Kennedy, John Fitzgerald"
"Kennedy-McJohnson, John Fitzgerald"
"Kennedy-McJohnson, John F."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}