// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Z][a-zA-Z]+(?:-[A-Z][a-zA-Z]+)?), ([A-Z][a-zA-Z]+\s*(?:[A-Z][a-zA-Z]+|[A-Z]\.)?)").unwrap();
let string = "\"Kennedy, John\"
\"Kennedy, John F.\"
\"Kennedy, John Fitzgerald\"
\"Kennedy-McJohnson, John Fitzgerald\"
\"Kennedy-McJohnson, John F.\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}