$re = '/([A-Z][a-zA-Z]+(?:-[A-Z][a-zA-Z]+)?), ([A-Z][a-zA-Z]+\s*(?:[A-Z][a-zA-Z]+|[A-Z]\.)?)/m';
$str = '"Kennedy, John"
"Kennedy, John F."
"Kennedy, John Fitzgerald"
"Kennedy-McJohnson, John Fitzgerald"
"Kennedy-McJohnson, John F."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);