import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^declare -a IP_LIST=\\(|(?!^)\\G)\\s*'([^']+)'(?=[^()]*\\))";
final String string = "declare -a IP_LIST=(\n"
+ " 'x.x.x.x/24'\n"
+ " 'x.x.x.x/24'\n"
+ " 'x.x.x.x/24'\n"
+ " 'x.x.x.x/24'\n"
+ " 'x.x.x.x/24'\n"
+ " 'x.x.x.x/28'\n"
+ ")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}