re = /(?:^declare -a IP_LIST=\(|(?!^)\G)\s*'([^']+)'(?=[^()]*\))/m
str = 'declare -a IP_LIST=(
\'x.x.x.x/24\'
\'x.x.x.x/24\'
\'x.x.x.x/24\'
\'x.x.x.x/24\'
\'x.x.x.x/24\'
\'x.x.x.x/28\'
)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end